Среда, 23.08.2017, 05:14
Вы вошли как Гость | Группа "Гости"Приветствую Вас Гость | RSS
Главная | Глюки прошивки, некорректная работа, ошибки - Форум | Мой профиль | Регистрация | Выход | Вход
Обитель RC-инженера
Форма входа
[ Новые сообщения · Участники · Правила форума · Поиск · RSS ]
Страница 1 из 212»
Модератор форума: ВитГо 
Форум » Системы управления моделями » Прошивка VCoder » Глюки прошивки, некорректная работа, ошибки
Глюки прошивки, некорректная работа, ошибки
ВитГоДата: Среда, 15.08.2012, 12:35 | Сообщение # 1
Полковник
Группа: Администраторы
Сообщений: 2428
Репутация: 19
Статус: Offline
Все выявленные глюки, ошибки и прочие "странности" пишем тут :-)
обещаю, что все написанное здесь читается и применяется !


Виталий (аka ВитГо)
 
ВитГоДата: Воскресенье, 07.10.2012, 04:12 | Сообщение # 2
Полковник
Группа: Администраторы
Сообщений: 2428
Репутация: 19
Статус: Offline
Господа, для общего удобства я создал тему Отчеты о выходе новых прошивок. Подписавшись на которую вы будете своевременно получать информацию о выходе новых версий прошивок.

Писать в ту тему не нужно, она именно для оповещения о выходе новых версий прошивки

p.s. добавлена новая версия прошивки cool


Виталий (аka ВитГо)
 
uwrteyДата: Понедельник, 17.02.2014, 00:23 | Сообщение # 3
Полковник
Группа: Администраторы
Сообщений: 2411
Репутация: 9
Статус: Offline
Из мануала:
Цитата

Осталось сохранить модель на V-DISK. Не пропускайте это этап – так как пока наша модель существует только во временной памяти и при выключении передатчика будет потеряна.

Для сохранения нужно перейти в меню FILE – SAVE AS.

Выбрать место для сохранения и нажать MENU. Наша модель сохранена! При следующем включении передатчика эта модель будет загружена автоматически (как последняя используемая) либо это можно сделать вручную через операцию FILE – OPEN MODEL. Если при последующих корректировках модели Вы забудете сохранить модель на V-DISK, то при выходе из меню Вам все равно будет предложено сделать сохранение или отказаться от этого.


На деле:
Если забудешь сохранить новую модель, то тебе программа предложит это сделать и если ты согласишься, то она сохранит эту модель НЕ как новую, а как отредактированную старую.
У меня так и получилось - потерял предыдущую модель.

Было бы прикольно, если бы программа предлагала сохранить, а при выборе "сохранить" предлагало место (ячейку) для сохранения.


что то я не успеваю за своими мыслями......

Сообщение отредактировал uwrtey - Понедельник, 17.02.2014, 07:27
 
uwrteyДата: Вторник, 03.06.2014, 23:42 | Сообщение # 4
Полковник
Группа: Администраторы
Сообщений: 2411
Репутация: 9
Статус: Offline
И еще нашел одну особенность.
в меню MIXERS>SOURCE> "значение"
Значения пролистывются по полному кругу ( зацикливаются ) только кнопкой "UP"
Если-же пролистывать кнопкой "DOWN" то зацикливания не происходит. Значение "упирается" в какой-то показатель, не помню точно какой, но помню что первый в списке!


что то я не успеваю за своими мыслями......

Сообщение отредактировал uwrtey - Вторник, 03.06.2014, 23:42
 
uwrteyДата: Вторник, 03.06.2014, 23:43 | Сообщение # 5
Полковник
Группа: Администраторы
Сообщений: 2411
Репутация: 9
Статус: Offline
Обнаружил еще один глюк.
Стики откалиброваны. В памяти сохранено три модели.
Первая просто содержит 8 пропорциональных каналов и все.
Вторая настроена для налета часов в симуляторе.
Третья настроена для полетов для ЛК "ВЖИК". Далее речь пойдет именно про эту модель.

Эту модель я настроил с помощью микшера. Все просто - я замиксовал два канала, на каждый канал добавил по 100% элероны и элеватор и получил элевоны.
Все - больше ни чего я не настраивал.
И только сегодня я заметил на графическом отображении положения стиков некий крен. ( ch1=1476; ch2=1522; крен составляет 46 единиц.. )
Сначала подумал, что калибровка сбилась. Хотел откалибровать, но почему то решил глянуть другую модель - а у нее все в порядке... Проверил еще одну модель - и у нее все в порядке! Что то тут не так....


что то я не успеваю за своими мыслями......

Сообщение отредактировал uwrtey - Вторник, 03.06.2014, 23:48
 
ВитГоДата: Среда, 04.06.2014, 00:48 | Сообщение # 6
Полковник
Группа: Администраторы
Сообщений: 2428
Репутация: 19
Статус: Offline
модель триммировал ? smile

скорее всего это результат триммирования
я обычно после основного триммирования правлю значения центров каналов и выставляю триммера в ноль...


Виталий (аka ВитГо)
 
uwrteyДата: Среда, 04.06.2014, 01:22 | Сообщение # 7
Полковник
Группа: Администраторы
Сообщений: 2411
Репутация: 9
Статус: Offline
Нет, не триммировал.

А если быть точнее, то тримировал но механически - у меня механические триммеры предусмотрены.. smile ( смотри фотку http://vg.ucoz.ru/_fr/1/3924661.jpg - там на конце тяги проволока изогнута и изменяя угол изгиба можно легко триммировать )

Вот я и не могу понять от куда этот глюк... surprised


что то я не успеваю за своими мыслями......

Сообщение отредактировал uwrtey - Среда, 04.06.2014, 09:41
 
ВитГоДата: Среда, 04.06.2014, 06:36 | Сообщение # 8
Полковник
Группа: Администраторы
Сообщений: 2428
Репутация: 19
Статус: Offline
дай видео или фотки

- экрана где ты увидел смещение
- экрана LCH MIDLE
- экрана LCH EPA


Виталий (аka ВитГо)
 
uwrteyДата: Среда, 04.06.2014, 10:27 | Сообщение # 9
Полковник
Группа: Администраторы
Сообщений: 2411
Репутация: 9
Статус: Offline


что то я не успеваю за своими мыслями......

Сообщение отредактировал uwrtey - Среда, 04.06.2014, 10:27
 
ВитГоДата: Среда, 04.06.2014, 13:58 | Сообщение # 10
Полковник
Группа: Администраторы
Сообщений: 2428
Репутация: 19
Статус: Offline
покажи настройки Channel - lch - epa
fly mode - lch midle


Виталий (аka ВитГо)
 
uwrteyДата: Среда, 04.06.2014, 16:44 | Сообщение # 11
Полковник
Группа: Администраторы
Сообщений: 2411
Репутация: 9
Статус: Offline
настройки Menu >Edit > Channels > Lch set > Lch epa
тут все каналы имеют значение
=1000 2000

настройки Menu > Edit > Fly modes > FModes 1 > Lch Middle
тут все каналы имеют значение
= 500 1500 500

Кстати обрати внимание на видео:
Когда я я включаю модель с названием "8channel", то первый и второй каналы имеют значение 1499.
А когда я включаю модель с названием "simulat", то первый и второй каналы принимают значение 1501 и 1502, хотя я не трогал стик... Может это как-то связано ?


что то я не успеваю за своими мыслями......
 
ВитГоДата: Среда, 04.06.2014, 20:39 | Сообщение # 12
Полковник
Группа: Администраторы
Сообщений: 2428
Репутация: 19
Статус: Offline
гм.. чудес не бывает, где то какая то настройка сидит...

в принципе самый простой способ это попробовать модель создать заново.. контролируя на каждом этапе генерацию сигналов..

обычно подобные смещения происходят из за микширования и триммирования

разница в 1-3 мкс - это погрешность микширования, в принципе серва реагирует на изменения длительности импульса где то на 5-7 мкс

кстати, а ты повторно (после создания старых моделей) не делал калибровку стиков ? попробуй сделать ! стики на аппаратуре дышат и значения дышат...


Виталий (аka ВитГо)
 
uwrteyДата: Среда, 04.06.2014, 21:31 | Сообщение # 13
Полковник
Группа: Администраторы
Сообщений: 2411
Репутация: 9
Статус: Offline
На сколько я помню, после настройки модели такого прикола не было, это появилось после последних полетушек ( хотя я могу ошибаться ).
Повторная калибровка решила проблему!


что то я не успеваю за своими мыслями......
 
ВитГоДата: Среда, 04.06.2014, 22:41 | Сообщение # 14
Полковник
Группа: Администраторы
Сообщений: 2428
Репутация: 19
Статус: Offline
Цитата uwrtey ()
Повторная калибровка решила проблему!

значит просто плывут стики.. плохо конечно.. :-(
люфта нет ?


Виталий (аka ВитГо)
 
uwrteyДата: Среда, 04.06.2014, 22:46 | Сообщение # 15
Полковник
Группа: Администраторы
Сообщений: 2411
Репутация: 9
Статус: Offline
нет... все ГУД..

что то я не успеваю за своими мыслями......
 
Форум » Системы управления моделями » Прошивка VCoder » Глюки прошивки, некорректная работа, ошибки
Страница 1 из 212»
Поиск:


Copyright MyCorp © 2017
Сделать бесплатный сайт с uCoz